Itika

SPIP 2.1

  • Un petit changement de look. Les icônes de la barre d’outil ont été rafraichies
  • Détection automatique des mises à jour de SPIP. Ça l’air sympa mais j’ai pas trouvé où c’était encore...
  • Intégration (comme extension) du plugin « porte-plume » qui améliore grandement l’édition des champs textes et offre une prévisualisation en cours d’édition. On voit effectivement dans la barre d’édition un petit système d’onglet qui bascule de « Éditer » à « Voir », très pratique !
  • L’édition est également améliorée, tout bête, mais si vous commencez à écrire une liste de puce avec -* et bien au retour chariot, le signe -* est rajouté automatiquement au début de la nouvelle ligne.
  • Possibilité de définir des thèmes graphiques (comme par exemple avec le plugin « themes_interface_privee »)
  • Une meilleure prise en charge de la compatibilité IE, avec notamment le support des couches alpha pour les format png. On remarque également dans les fonctions avancées une nouvelle section compatibilité IE et des hack CSS inscrit par default (Séb doit pouvoir nous en dire plus).
  • Nouvelle interface de gestion des plugins.

On en profite d’ailleurs pour mettre à jours ces listes : dans “ajouter des plugins” on ne voit plus aucune liste de plugin disponible. On peut d’ailleurs voir maintenant un bouton “mettre à jours vos listes”. Et automatiquement la date de dernière syndication des listes rss des plugins se met à jour. Ici on voit le nombre de plugin avec spip 2.0, les anciennes listes avant que je les supprime et les nouvelles liste avec spip 2.1

Et en-dessous apparait alors la liste des plugins disponible avec leur descriptions. Ça prend plus de place qu’avant mais c’est peut-être plus clair.

  • Gestion d’un nouveau répertoire (extensions/) pour y placer ces plugins actifs dès l’installation et non désactivables. On peut d’ailleurs voir dans l’interface d’administration des plugins, une section extensions avec des fonctionnalités du noyau de spip qui ont été déplacé en extension. La modularité est la ligne de mire des prochaines version de spip.
  • Homogénéisation des balises #LOGO_ : les paramètres sont désormais passés entre accolades et disparition des « doubles pipes » (#LOGO_xxx||filtre (écriture obsolète mais toutefois encore fonctionnelle)
  • Apparition de nouvelles balises et fonctions : #BOUTON_ACTION, |balise_img, |couleur_luminance (similaire à |couleur_saturation, mais agissant sur l’intensité lumineuse de la couleur)
  • Amélioration du débuggueur désormais capable d’indiquer la ligne fautive dans un squelette

Incompatibilité

De notre coté sur notre spip, des incompatibilités ont commencé à montrer le bout de leur nez. Voici un récap de mes mises à jours de plugins :

  • Acces Restreint 3.0 : Pas dans la liste des plugins 2.1, mais à voir si il ne fonctionne pas en l’état.
  • cfg : moteur de configuration ->mise a jours OK
  • Champs Extras2 1.1.1 -> 1.5.3
  • Interface pour Champs Extras 0.7.3 -> 1.1.0 Nécessite le plugin SAISIES en version [1.6.1 ;] minimum Et je n’ai pas perdu mes champs extra. Il faut ensuite désactiver les anciennes versions et activer les nouvelles mais pas de mauvaise surprise
  • Changez de navigateur ! 1.1 stable ok
  • CKEditor pour SPIP 0.9.160 - en test : pas dans la liste encore des disponible
  • Lecteur Multimédia en Flash (MP3,flv) 0.68 - en développement -> 0.73 - en développement
  • Liens spip_out ouvrants 1.0 - stable Compatible 2.1 ok, il est bien dans la liste et je l’ai ré-installé au cas ou.
  • SPIP Bonux 2.0 1.8.4 - stable -> 1.9.3 - stable OK pour 2.1

Au sujet du code, j’en ai également noté. Une liste détaillé est disponible sur le site de spip. Et effectivement j’ai du revoir mes vieux filtres reduire_image qui avait été renommés en image_réduire déjà depuis spip 2.0. Mais ils marchaient encore, plus maintenant. Et on apprécie le fait de pouvoir utiliser des simples | sur les balise #LOGO.

Cliquer pour donner un point Google :



Haut de page

Tous droits réservés ©2016 | Partenaires : Portage salarial